nukeSEO.com - PHPNuke SEO Search engine optimization, professional tools including nukeSEO, nukeSPAM, nukeFEED, nukePIE, nukeWYSIWYG and more

 

. Welcome to nukeSEO.com  ! 
.
.
.

Tag This



.
nukeSEO.com: Forums


 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

love nukeseo but frustrated with google submission errors
 
 
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeSEO (tm)
View previous topic :: View next topic  
Author Message
nickvivid
webmaster


Joined: Jun 15, 2007
Posts: 5

PostPosted: Wed Oct 01, 2008 10:27 pm    Post subject: love nukeseo but frustrated with google submission errors Reply with quote

Hey I really love nukeseo as it's been a very valuable asset to keyword analyzing and all that. But I've been trying in vain for weeks to get the sitemaps working with google. I've installed it correctly, disabled the modules that I didn't want included (which leaves the forums and faqs of my site as the main parts of my sitemap), and it displays ok in the browser, but I have validation errors when I submit to google. I've tried several ways to change the headers, anything to make it compliant, and haven't figured it out. Please help. My site is here:

Only registered users can see links on this board! Get registered or login!

and

Only registered users can see links on this board! Get registered or login!
  
Back to top
View user's profile Send private message
Guardian
webmaster


Joined: Dec 25, 2005
Posts: 364
Location: Vsetin, Czech Republic

PostPosted: Thu Oct 02, 2008 1:55 am    Post subject: Re: love nukeseo but frustrated with google submission error Reply with quote

The errors that Google is giving you might be useful but I suspect it is probably something about illegal characters?
I see you are using square brackets in some places which I do not think is a legal XML character.
  
Back to top
View user's profile Send private message
nickvivid
PostPosted: Thu Oct 02, 2008 8:08 am    Post subject: Re: love nukeseo but frustrated with google submission error Reply with quote

The current error is:

Parsing error
We were unable to read your Sitemap. It may contain an entry we are unable to recognize. Please validate your Sitemap before resubmitting

So there probably are illegal characters, i'll try changing the brackets. Can I add some code to the index.php file to re-write any illegal characters as legal ones?
  
Back to top
nickvivid
PostPosted: Thu Oct 02, 2008 8:17 am    Post subject: Re: love nukeseo but frustrated with google submission error Reply with quote

Tried checking it at validome and w3.org.

W3.org report:

Error: Expected whitespace after public id
in unnamed entity at line 1 char 63 of Only registered users can see links on this board! Get registered or login!

Validome report:

Document contains a DTD.
As it can not be guaranteed that the DTD contains the processing rules for Google Sitemap, the document can not be validated.
Remove the DTD and try to revalidate the document.
  
Back to top
Susann
webmaster


Joined: Dec 26, 2005
Posts: 35
Location: Germany

PostPosted: Thu Oct 02, 2008 10:31 am    Post subject: Re: love nukeseo but frustrated with google submission error Reply with quote

You need to fix this on line 1 I quess I tried to view your source code but its impossible. Also Firefox hangs and there is no feedback if I try your sitemap.
I had similar errors and solved everything. It isnīt so hard to solve these validation errors.My sitemap.html is valid.
  
Back to top
View user's profile Send private message Visit poster's website
nickvivid
PostPosted: Thu Oct 02, 2008 1:33 pm    Post subject: Re: love nukeseo but frustrated with google submission error Reply with quote

ok interesting, if it's line 1, line 1 is:

Code:
<?xml version="1.0" encoding="UTF-8"?>


Line 2 is (which appears as line 1 when viewing the source)

Code:
<urlset xsi:schemaLocation="http://www.google.com/schemas/sitemap/0.84 http://www.google.com/schemas/sitemap/0.84/sitemap.xsd">


When viewing the source in an editor, it appears as:

Code:
<urlset xmlns="http://www.google.com/schemas/sitemap/0.84" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.google.com/schemas/sitemap/0.84 http://www.google.com/schemas/sitemap/0.84/sitemap.xsd"><!-- Created by nukeSEO Sitemap 1.0B --><!-- Updated on 2008-10-02T14:10:42-0400 -->


When looking at google's rules for header information, they mention the schema should be .9, not .84 - trying that doesn't work either

Code:
<?xml version='1.0' encoding='UTF-8'?>

   <urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
   xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9
   http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd">


So I'm not sure what line 1 really is and what may possibly be wrong with it. Can you explain a little more susann what part of the code I need to look at and what I need to change?
  
Back to top
nickvivid
PostPosted: Thu Oct 02, 2008 3:54 pm    Post subject: Re: love nukeseo but frustrated with google submission error Reply with quote

Perhaps this is a problem with my apache server? When looking at the page with IE, the page crashes on loading around 125898 everytiime and corrupts the rest of the file. If this is the case, is there a way to limit the amount of urls in the sitemap to something like 5000 or 10,000?

here's the last few lines of the corrupted data:

<lastmod>2008-10-02T16:10:58-05:00</

AN> <changefreq>daily</changefreq>
  
Back to top
Susann
PostPosted: Sat Oct 04, 2008 8:16 am    Post subject: Re: love nukeseo but frustrated with google submission error Reply with quote

Quess my problem was a bit different different: Only registered users can see links on this board! Get registered or login!

After I corrected some things I wrote in the thread the browser never crashed when loading sitemap.html.

"This document was successfully checked as XHTML 1.0 Transitional" is what I get from W3C and when I use the Google sitemap validator at validome I get the same notice like you but I used the other validator there and my sitemap.html is full valid.
On line 1 I have:
<?xml version="1.0" encoding="iso-8859-1"?>
  
Back to top
Display posts from previous:       
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeSEO (tm) All times are GMT - 5 Hours
 
 Page 1 of 1

 

Jump to:   
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001-2008 phpBB Group


Page Generation: 0.05 Seconds