nukeSEO.com - PHPNuke SEO Search engine optimization, professional tools including nukeSEO, nukeSPAM, nukeFEED, nukePIE, nukeWYSIWYG and more

 

. Welcome to nukeSEO.com  ! 
.
.
.

Tag This



.
nukeSEO.com: Forums


 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Errors with Social Bookmarking links
 
 
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeSEO (tm)
View previous topic :: View next topic  
Author Message
amber222
webmaster


Joined: Mar 11, 2008
Posts: 19

PostPosted: Wed Mar 26, 2008 7:59 pm    Post subject: Errors with Social Bookmarking links Reply with quote

I added StumbleUpon to the social bookmarking links. I used the code for Reddit as an example. Now I am noticing that for both Reddit and StumbleUpon, the links have "25" in places throughout. When I submit to StumbleUpon, I am taken to a bad url link. I haven't tried submitting to Reddit yet, but I can see the same thing in those links.

Here is an example of the link produced for StumbleUpon:

Code:
http://www.stumbleupon.com/submit?url=http%253A%252F%252Fwww.mccogic.org

%252Fmodules.php%253Fname%253DNews%2526file%253Darticle%2526sid%253D
&title=Naomi+Watts%253A+%2527Funny+Games%2527+Interview


You can see the 25 before each item.

Here is the code from includes/nukeSEO_SB.php:

Code:
$bookmarks["reddit"] = array ( 

               "siteurl"   => "http://reddit.com/submit?url={MYNUKEURL}&title={MYNUKETITLE}",
               "siteimgsm"   => "images/socialbookmarks/reddit_sm.png",
               "siteimglg"   => "images/socialbookmarks/reddit.png",
               "imgalt"   => "reddit this"
            );
$bookmarks["stumbleupon"] = array (
               "siteurl"   => "http://stumbleupon.com/submit?url={MYNUKEURL}&title={MYNUKETITLE}",
               "siteimgsm"   => "images/socialbookmarks/stumbleupon_sm.gif",
               "siteimglg"   => "images/socialbookmarks/stumbleupon.gif",
               "imgalt"   => "stumbleupon this"
            );


Any idea what could be causing this and how I can fix it.
  
Back to top
View user's profile Send private message
Guardian
webmaster


Joined: Dec 25, 2005
Posts: 364
Location: Vsetin, Czech Republic

PostPosted: Thu Mar 27, 2008 12:49 pm    Post subject: Re: Errors with Social Bookmarking links Reply with quote

I do not see any reason why that wouldn't work. The file seems to use a htmlentities check to get rid of garbage like that.
Which version of nuke are you using?
I tried to check your site (presumably it's the one in the url you posted) but it gave me an error.
  
Back to top
View user's profile Send private message
amber222
PostPosted: Thu Mar 27, 2008 1:21 pm    Post subject: Re: Errors with Social Bookmarking links Reply with quote

I am using Ravennuke 2.20.01. Visit our test site at Only registered users can see links on this board! Get registered or login! - click on the sb link for reddit and see that it adds "25" throughout the url. StumbleUpon forwards to a bad url page. The Digg link works fine since I changed $s_sid to $sid in index.php to get the article ID number. I haven't tested the other links yet.
  
Back to top
Guardian
PostPosted: Thu Mar 27, 2008 5:02 pm    Post subject: Re: Errors with Social Bookmarking links Reply with quote

I get a 403 forbidden error message on that page to.
  
Back to top
amber222
PostPosted: Thu Mar 27, 2008 6:23 pm    Post subject: Re: Errors with Social Bookmarking links Reply with quote

The only thing I can think of is if Nuke Sentinel has blocked your IP. Can you pm me with your IP?
  
Back to top
amber222
PostPosted: Thu Mar 27, 2008 11:59 pm    Post subject: Re: Errors with Social Bookmarking links Reply with quote

Ok. I think I found your IP in my logs and removed the block.
  
Back to top
Guardian
PostPosted: Fri Mar 28, 2008 3:53 am    Post subject: Re: Errors with Social Bookmarking links Reply with quote

The url is being formed correctly on your site, that is to say, there are no htmlentities in the url so this seems to indicate it is being mutilated at the site you are sending the link to for some reason.
I think that it might be getting mutilated because the link is not built correctly on your site for them to interpret the data.
  
Back to top
amber222
PostPosted: Fri Mar 28, 2008 9:29 am    Post subject: Re: Errors with Social Bookmarking links Reply with quote

Guardian wrote:
I think that it might be getting mutilated because the link is not built correctly on your site for them to interpret the data.


I don't know what you mean by "not built correctly." Are you saying this is because of the Ravennuke version I am using? The same thing happens on other Ravennuke sites where I have added the Social Bookmarking Links. Why do the other links work but just not these two? Should I post at the Ravennuke forum for help with this?
  
Back to top
Guardian
PostPosted: Fri Mar 28, 2008 3:08 pm    Post subject: Re: Errors with Social Bookmarking links Reply with quote

No, what I meant was that different social bookmarking sites need the data sent to them in a specific way so it knows what the data is and how to handle it.
For example if you look at the reddit link
Code:


"siteurl"   => "http://reddit.com/submit?url={MYNUKEURL}&title={MYNUKETITLE}",

You can see that reddit 'knows' to expect a url when it finds in the link url= and it expects to find the title of the link after title= so you need to check to make sure that is correct.
If I remember correctly it is actually correct and the link appears correctly when I hover over the link on your site.
  
Back to top
amber222
PostPosted: Sun Mar 30, 2008 3:02 am    Post subject: Re: Errors with Social Bookmarking links Reply with quote

I had checked this a couple of times, but after reading your post and checking again, I found a really dumb mistake with StumbleUpon. I forgot the Only registered users can see links on this board! Get registered or login! in their address. I finally broke down and joined both StumbleUpon and Reddit myself (which I hadn't wanted to do). I tested again, and it works fine now.

Thanks, and sorry for wasting your time.
  
Back to top
Display posts from previous:       
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeSEO (tm) All times are GMT - 5 Hours
 
 Page 1 of 1

 

Jump to:   
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001-2008 phpBB Group


Page Generation: 0.06 Seconds