nukeSEO.com - PHPNuke SEO Search engine optimization, professional tools including nukeSEO, nukeSPAM, nukeFEED, nukePIE, nukeWYSIWYG and more

 

. Welcome to nukeSEO.com  ! 
.
.
.

Tag This



.
nukeSEO.com: Forums


 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

help needed installing i have an error
 Goto page 1, 2  Next
 
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeWYSIWYG (tm)
View previous topic :: View next topic  
Author Message
jennifer
webmaster


Joined: Jan 26, 2008
Posts: 12

PostPosted: Sat Jan 26, 2008 9:43 am    Post subject: help needed installing i have an error Reply with quote

I am installling this on a nukePlatinum site.

When I make the config.php edit all is well.

When I make the mainfile.php edit a white page displays.

I have checked the changes at least 10 times.
I have tried your direct linking method to check for parse errors. I get redirected to index.php which loads on the left side and the header. The background shows white instead of the graphics.

I am providing a direct link to a zip file with the mainfile.php in it.

Any help would be appreciated. I seldom work with platinum. I have searched this site and the futurenuke site.

Thank you in advance.

This is the edited version for the editor.
Only registered users can see links on this board! Get registered or login!

Here is the original file.
Only registered users can see links on this board! Get registered or login!


Also, I have turned error reporting on in config.php and show nothing.
  
Back to top
View user's profile Send private message
kguske
Site Admin
Site Admin


Joined: May 12, 2005
Posts: 875

PostPosted: Sat Jan 26, 2008 12:14 pm    Post subject: Re: help needed installing i have an error Reply with quote

Nothing wrong with the mainfile that I can see - I checked the source file using the direct link as you did and found nothing. Where do you see a white page? On every page, or only on pages with the editor?
_________________
  
Back to top
View user's profile Send private message Visit poster's website
jennifer
PostPosted: Sat Jan 26, 2008 12:57 pm    Post subject: Re: help needed installing i have an error Reply with quote

I replaced the mainfile on there now with the original to give them site functionality for now. It is on all pages. When trying to view the site. Would you like me to put the edited one in action now? Please let me know. Thank you
  
Back to top
kguske
PostPosted: Sat Jan 26, 2008 3:04 pm    Post subject: Re: help needed installing i have an error Reply with quote

That might happen if the rest of the nukeWYSIWYG files haven't been installed - can you check the includes/FCKeditor directory?
  
Back to top
jennifer
PostPosted: Sat Jan 26, 2008 3:08 pm    Post subject: Re: help needed installing i have an error Reply with quote

Hi, yes, I can check it. I have installed them all twice. Did you have something in particular in mind to check?

Also, possibly a dumb question, but do the other file edits, such as news index.php have to be done at the same time as the mainfile and config edits? Since the site went "white" after the mainfile changes, I did not do the additonal "textarea" changes in any modules.

I don't believe that those things are related. The site should still show but the editor not work without the "textarea" changes, yes?
  
Back to top
kguske
PostPosted: Sat Jan 26, 2008 3:39 pm    Post subject: Re: help needed installing i have an error Reply with quote

The other edits don't have to be in place for the site to work, but obviously you won't have the editor working correctly without those edits. Were any other files modified - or just config.php and mainfile.php? Are you switching config.php back and forth along with mainfile?

Is there anything in your site error log? This isn't the same as turning on display errors in the script.
  
Back to top
jennifer
PostPosted: Sat Jan 26, 2008 3:41 pm    Post subject: Re: help needed installing i have an error Reply with quote

Hi,

No, just the config and mainfile edits. That is all that I have done. There is nothing in the sites error logs either. I checked there when it started. I neglected to mention that here.

Would you like to activate the edited mainfile on the site?
  
Back to top
kguske
PostPosted: Sat Jan 26, 2008 3:54 pm    Post subject: Re: help needed installing i have an error Reply with quote

Based on what you've reported, I don't think that will help since it isn't a parsing error and there are no errors in the logs.

Another possibility is that there is a conflict with the additional functions already defined somewhere else. But that would show up if you had display errors on.

Can you check for includes/kses/kses.php ?
  
Back to top
jennifer
PostPosted: Sat Jan 26, 2008 3:55 pm    Post subject: Re: help needed installing i have an error Reply with quote

yes, what should I check it for?
  
Back to top
jennifer
PostPosted: Sat Jan 26, 2008 3:58 pm    Post subject: Re: help needed installing i have an error Reply with quote

as an update. I have just now noticed that it is only index.php that will show "white". Admin and forums, etc are working.
  
Back to top
kguske
PostPosted: Sat Jan 26, 2008 4:02 pm    Post subject: Re: help needed installing i have an error Reply with quote

Make sure that your modules/News/index.php page did not change. If you replace it with one that came with nukeWYSIWYG, it might not work for NukePlatinum (you'll need to modify the one that came with Nuke Platinum).
  
Back to top
jennifer
PostPosted: Sat Jan 26, 2008 4:05 pm    Post subject: Re: help needed installing i have an error Reply with quote

Hi,

Those were not edited. To be safe, I just uploaded the backups of admin/index.php and index.php within the News module. Still, the home page is white as you can see if you got the website right now. Thanks
  
Back to top
jennifer
PostPosted: Sat Jan 26, 2008 4:42 pm    Post subject: Re: help needed installing i have an error Reply with quote

I have also deactivated the news module and placed something else in home to no avail. Any ideas would be very helpful. Thank you.
  
Back to top
jennifer
PostPosted: Sat Jan 26, 2008 4:55 pm    Post subject: Re: help needed installing i have an error Reply with quote

Now, I am getting somewhere.

I put the fisubice theme up. Only the header will load on any given page. Upon clicking the home link I finally get an error message.

Code:
Fatal error: Call to undefined function: kses_no_null() in /home/*****/public_html/DC/mainfile.php on line 975


How do I remedy this?

Thank you.
  

Last edited by jennifer on Sat Jan 26, 2008 7:48 pm; edited 1 time in total
Back to top
kguske
PostPosted: Sat Jan 26, 2008 5:57 pm    Post subject: Re: help needed installing i have an error Reply with quote

Nuke Platinum must not use the patched code. The problem is in
Code:
function check_html(

The line causing the problem is:
Code:
        @include_once(INCLUDE_PATH.'includes/kses/kses.php');

specifically the INCLUDE_PATH define.

Put something this near the top of your mainfile.php:
Code:
if(defined('FORUM_ADMIN')) define('INCLUDE_PATH', '../../../');

elseif(defined('INSIDE_MOD')) define('INCLUDE_PATH', '../../');
else define('INCLUDE_PATH', './');


Since nukeWYSIWYG doesn't apply to the forums anyway, it won't matter that the first 2 lines may not get executed because your version of Nuke Platinum doesn't have the latest Patch files from Nuke Resources (one of the requirements listed in the readme).

Let me know if that doesn't solve the problem.
  
Back to top
Display posts from previous:       
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeWYSIWYG (tm) All times are GMT - 5 Hours
 Goto page 1, 2  Next
 Page 1 of 2

 

Jump to:   
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001-2008 phpBB Group


Page Generation: 0.10 Seconds