nukeSEO.com - PHPNuke SEO Search engine optimization, professional tools including nukeSEO, nukeSPAM, nukeFEED, nukePIE, nukeWYSIWYG and more

 

. Welcome to nukeSEO.com  ! 
.
.
.

Tag This



.
nukeSEO.com: Forums


 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Problem with Nuke 7.6 patched 3.2
 
 
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeWYSIWYG (tm)
View previous topic :: View next topic  
Author Message
Paul_K
webmaster


Joined: Jan 15, 2007
Posts: 7

PostPosted: Tue Jan 16, 2007 10:20 am    Post subject: Problem with Nuke 7.6 patched 3.2 Reply with quote

Hi,

First off, thanks for a great looking mod Smile I had originally installed 7.9 just for the MCE editor but deleted it under advisement and went back to 7.6.

Anyway, my problem... I installed today, uploaded all files and modified mainfile.php and config.php accordingly. So far so good! However once I modify the index.php of the submit news module I get issues. Anyone clicking it will get a blank screen (I believe this is a PHP parsing error?)

The only thing I can find is this slight anomaly in my index.php, according to the readme it should look like

Code:
echo "<br><br>"

        ."<b>"._STORYTEXT.":</b> ("._HTMLISFINE.")<br>
        ."<textarea cols=\"50\" rows=\"12\" name=\"story\"></textarea><br>";


But mine appears to look like

Code:
   echo "<br><br>"

        ."<b>"._STORYTEXT.":</b> ("._HTMLISFINE.")<br>"
   ."<textarea cols=\"50\" rows=\"12\" name=\"story\"></textarea><br>"


Basically I appear to have an extra " on the first line and a missing ; on the second line. Commenting the second line out and adding

Code:
wysiwyg_textarea("story", "", "NukeUser", "50", "12");


Will give me the blank screen errors Sad

Any ideas people?

Cheers. Paul K
  
Back to top
View user's profile Send private message
Paul_K
PostPosted: Tue Jan 16, 2007 9:25 pm    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

edited....
  

Last edited by Paul_K on Thu Jan 18, 2007 2:26 pm; edited 1 time in total
Back to top
kguske
Site Admin
Site Admin


Joined: May 12, 2005
Posts: 875

PostPosted: Tue Jan 16, 2007 11:44 pm    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

In the first post, you need the extra " and also the closing ;

Is there a problem in the second post?
_________________
  
Back to top
View user's profile Send private message Visit poster's website
Paul_K
PostPosted: Wed Jan 17, 2007 1:10 pm    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

Alright, now maybe I'm missing something obvious? Maybe I'm just incredibly stupid but I just can't make sense of this Sad

I apologize for the numerous postings of code below btw...

Original code before edit...

Code:


   echo "<br><br>"
        ."<b>"._STORYTEXT.":</b> ("._HTMLISFINE.")<br>"
   ."<textarea cols=\"50\" rows=\"12\" name=\"story\"></textarea><br>"
        ."<br><br><b>"._EXTENDEDTEXT.":</b><br>"


Code after being edited according to the readme.txt file, and which causes a blank screen..

Code:


   echo "<br><br>"
        ."<b>"._STORYTEXT.":</b> ("._HTMLISFINE.")<br>";
#   ."<textarea cols=\"50\" rows=\"12\" name=\"story\"></textarea><br>"
   wysiwyg_textarea("story", "", "NukeUser", "50", "12");
        ."<br><br><b>"._EXTENDEDTEXT.":</b><br>"


Code that will display the WYSIWYG editor but that will not show the "Extended text" label or box on screen...

Code:


echo "<br><br>"
        ."<b>"._STORYTEXT.":</b> ("._HTMLISFINE.")<br>";
#   ."<textarea cols=\"50\" rows=\"12\" name=\"story\"></textarea><br>"
   wysiwyg_textarea("story", "", "NukeUser", "50", "12")
        ."<br><br><b>"._EXTENDEDTEXT.":</b><br>"


I just don't know what the f**k I'm doing here! If it is something really obvious will someone just slap me in the face and tell me what's going on!

Cheers, Paul K
  
Back to top
Paul_K
PostPosted: Thu Jan 18, 2007 2:25 pm    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

No matter, fixed it myself. Turned on error reporting and figured it out. Looks like I was closing it early with the ; and just putting a comma in front of the wysiwyg bit made it run perfectly Smile

Code:
echo "<br><br>"

        ."<b>"._STORYTEXT.":</b> ("._HTMLISFINE.")<br>"
#   ."<textarea cols=\"50\" rows=\"12\" name=\"story\"></textarea><br>"
   ,wysiwyg_textarea("story", "", "NukeUser", "50", "12")
        ."<br><br><b>"._EXTENDEDTEXT.":</b><br>"
      ,wysiwyg_textarea("storyext", "", "NukeUser", "50", "12")
#   ."<textarea cols=\"50\" rows=\"12\" name=\"storyext\"></textarea><br>"
   ."("._AREYOUSURE.")</font><br><br>"
        ."<font class=\"content\">"._ALLOWEDHTML."<br>";


Cheers, Paul K
  
Back to top
kguske
PostPosted: Thu Jan 18, 2007 9:02 pm    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

Great...thanks for the followup.
  
Back to top
Neph
Newbie
Newbie


Joined: Jan 31, 2007
Posts: 3

PostPosted: Wed Jan 31, 2007 1:17 am    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

I too get the blank screen, I've made the changes Paul has to the file but it has not help me from getting a blank screen when I or someone else go to submit news. Here are my file that I have edited if someone can have a look to see if it's right. Only registered users can see links on this board! Get registered or login!

Thanks

Sean
  
Back to top
View user's profile Send private message
Paul_K
PostPosted: Wed Jan 31, 2007 6:02 am    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

Hi,

The best piece of advice I could give you would be to turn on error reporting in config.php and go from there. I scratched my head for ages but the minute i turned reporting on I had it licked in a few minutes.

You could always post the results here...

Cheers, Paul K
  
Back to top
Neph
PostPosted: Wed Jan 31, 2007 11:24 am    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

Turned on error reporting and this is what it give:

Parse error: syntax error, unexpected '.' in /home/room719/public_html/lockerroom/modules/Submit_News/index.php on line 93.

posted are lines 90-95

Code:
       ."<b>"._STORYTEXT.":</b> ("._HTMLISFINE.")<br>"

#   ."<textarea cols=\"50\" rows=\"12\" name=\"story\"></textarea><br>"
   wysiwyg_textarea("story", "", "NukeUser", "50", "12");
             ."<br><br><b>"._EXTENDEDTEXT.":</b><br>"
   ."<textarea cols=\"50\" rows=\"12\" name=\"storyext\"></textarea><br>"
   ."("._AREYOUSURE.")</font><br><br>"
  
Back to top
Paul_K
PostPosted: Wed Jan 31, 2007 12:13 pm    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

Hi,

Well, my line 92 is slightly different than yours, but I'm no php expert so who knows if that's it?

Code:
,wysiwyg_textarea("story", "", "NukeUser", "50", "12") 


Is that uploaded file the one giving errors? Try this one.. Only registered users can see links on this board! Get registered or login!

Cheers, Paul K
  
Back to top
Neph
PostPosted: Wed Jan 31, 2007 3:13 pm    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

Thanks for the help Paul

I removed the "." at the start of this line then the page fired up.

Code:
."<br><br><b>"._EXTENDEDTEXT.":</b><br>"


thanks again.

Sean
  
Back to top
Paul_K
PostPosted: Wed Jan 31, 2007 3:20 pm    Post subject: Re: Problem with Nuke 7.6 patched 3.2 Reply with quote

Glad you got it working, don't thank me as I don't truly understand how it works! I uploaded your index file above so that the editor should appear for both normal and advanced text.

Cheers, Paul K
  
Back to top
Display posts from previous:       
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeWYSIWYG (tm) All times are GMT - 5 Hours
 
 Page 1 of 1

 

Jump to:   
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001-2008 phpBB Group


Page Generation: 0.06 Seconds