nukeSEO.com - PHPNuke SEO Search engine optimization, professional tools including nukeSEO, nukeSPAM, nukeFEED, nukePIE, nukeWYSIWYG and more

 

. Welcome to nukeSEO.com  ! 
.
.
.

Tag This



.
nukeSEO.com: Forums


 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Problem installing WYSIWYG
 
 
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeWYSIWYG (tm)
View previous topic :: View next topic  
Author Message
shimshon
webmaster


Joined: Aug 12, 2006
Posts: 7

PostPosted: Sun Aug 27, 2006 12:06 pm    Post subject: Problem installing WYSIWYG Reply with quote

Hi,

I have been trying to install WYSIWYG I uploaded all files like described in the instruction.
My problem starts when I modefy the code.
I think I did everything fine with config.php & mainfile.php but I have problems with this:
Quote:

4. For the standard "display-as-you-go" approach, replace textarea HTML tags in modules and
admin scripts with a PHP call to function wysiwyg_textarea with 5 arguments:
textarea name, textarea value, the toolbar set name, textarea columns and textarea rows.
For example, in modules/Submit_News/index.php:

echo "<br><br>"
.""._STORYTEXT.": ("._HTMLISFINE.")<br>
."<textarea cols=\"50\" rows=\"12\" name=\"story\"></textarea><br>";

becomes:

echo "<br><br>"
.""._STORYTEXT.": ("._HTMLISFINE.")<br>";
# ."<textarea cols=\"50\" rows=\"12\" name=\"story\"></textarea><br>"
wysiwyg_textarea("story", "", "NukeUser", "50", "12");

If there is a value between the <textarea> and </textarea>, tags, that should be
specified as the second argument in the wysiwyg_textarea function call.

The 3rd argument defines the toolbar set, which controls which functions are available
to the user. Since these functions can present security risks, this should be chosen
carefully. By default, the most limited toolset bar will be chosen. In admin functions,
you may choose to use PHPNukeAdmin which loads all FCKeditor functions. The NukeUser
toolbar set is more limited, more secure and loads faster.

The textarea columns and rows are used in the event the WYSIWYG editor is turned off.
Rows are used to control the height of the text editor when the WYSIWYG editor is on.

NOTE: The name of the first argument cannot contain reserved HTML tags, e.g. description
contains SCRIPT. This requires that the fields be renamed.


I tried it but it didn't work.
Something is going wrong.
Does anybody has a more understandeble instruction? (for newbees)
Also I noticed that I can't access my site properly anymore....
see it at Only registered users can see links on this board! Get registered or login!
Thanks
  

Last edited by shimshon on Mon Aug 28, 2006 3:18 pm; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
kguske
Site Admin
Site Admin


Joined: May 12, 2005
Posts: 875

PostPosted: Sun Aug 27, 2006 9:26 pm    Post subject: Re: Problem installing WYSIWYG Reply with quote

That instruction shouldn't apply to the config.php or mainfile.php. If you can email your config.php and mainfile.php, or whichever files you edited, I'll take a look and repair.
_________________
  
Back to top
View user's profile Send private message Visit poster's website
shimshon
PostPosted: Mon Aug 28, 2006 3:20 pm    Post subject: Re: Problem installing WYSIWYG Reply with quote

Wich files should I edit anyway?
I did the config and main file and the index. Are there any other files I should edit?
  
Back to top
kguske
PostPosted: Mon Aug 28, 2006 4:38 pm    Post subject: Re: Problem installing WYSIWYG Reply with quote

You can edit any file the currently uses a textarea that you want to use the WYSIWYG editor. Submit news, admin blocks, admin messages are some that come to mind.
  
Back to top
Ohem
webmaster


Joined: Mar 21, 2007
Posts: 7

PostPosted: Mon Apr 02, 2007 1:14 pm    Post subject: Re: Problem installing WYSIWYG Reply with quote

Got the same problem, ecxept getting a blank page in submit_news. What's wrong? I've followed the readme as it tells me what to do.

I'm using 7.6 patch 3.3, a clean installation.

Edit:

Got it working on submit_news, but how do i do with News section of adding news and other places?

Edit 2:

Alright i managed to activate the editor in the News section but the text that is written in the editor and added in the news sectionwon't show up. What and where have i done wrong? It's the same in "Messages" section.
  
Back to top
View user's profile Send private message
kguske
PostPosted: Mon Apr 02, 2007 3:49 pm    Post subject: Re: Problem installing WYSIWYG Reply with quote

Most likely there is an issue with the change files for news and messages. If you like, send an email to kguske at nukeseo dot com with the changes files attached, and I'll have a look.
  
Back to top
Ohem
PostPosted: Wed Apr 04, 2007 1:03 pm    Post subject: Re: Problem installing WYSIWYG Reply with quote

Alright i managed to make it work but there'a problem. Adding News/Messages/Content is no problem at all, in fact it works great BUT, everytime I'm gonna edit a post the whole text is gone. It's not after the text has been edited, the text is gone from the time i press edit.

Edit:

Alright i found the problem, by filling out the value with "$hometext" and "$bodytext" in every <textarea> as the second argument, the posted message/ext popped out when i went for edit mode.

The whole line is set like this:

Code:


   ,wysiwyg_textarea("hometext", "$hometext", "NukeUser", "100", "15")


And so on with the other textareas.
  
Back to top
kguske
PostPosted: Sun Apr 08, 2007 12:35 pm    Post subject: Re: Problem installing WYSIWYG Reply with quote

Looks correct. I guess we should make the installation instructions more specific or add more examples. A little confusing...
  
Back to top
Ohem
PostPosted: Sun Apr 08, 2007 4:13 pm    Post subject: Re: Problem installing WYSIWYG Reply with quote

kguske wrote:
Looks correct. I guess we should make the installation instructions more specific or add more examples. A little confusing...


I'd say both, I've spent a couple of days (around 4) with this editor and so far i only got problem with the "News" section but everything works fine. (I know, it's a long time spending but wth!).

The "News" section only needs to be edited for adding news around (at least in PHP-Nuke 8 ) line 1647 in modules/News/admin/index.php. Don't remember what line when you're editing, will look into it. Not fun spending time in modifying every line with the same code.
  
Back to top
shiker
Newbie
Newbie


Joined: Apr 24, 2007
Posts: 1

PostPosted: Sat Apr 28, 2007 2:56 pm    Post subject: Re: Problem installing WYSIWYG Reply with quote

Ohem wrote:
Got the same problem, ecxept getting a blank page in submit_news. What's wrong? I've followed the readme as it tells me what to do.

I'm using 7.6 patch 3.3, a clean installation.

Edit:

Got it working on submit_news, but how do i do with News section of adding news and other places?

Edit 2:

Alright i managed to activate the editor in the News section but the text that is written in the editor and added in the news sectionwon't show up. What and where have i done wrong? It's the same in "Messages" section.


how did you go it working on submit_news module ?
what lines did you replaced ? Neutral
  
Back to top
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic    nukeSEO.com Forum Index -> nukeWYSIWYG (tm) All times are GMT - 5 Hours
 
 Page 1 of 1

 

Jump to:   
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001-2008 phpBB Group


Page Generation: 0.09 Seconds